PokeBase Battle Subway Meta-PokeBase Q&A

People with '&' in their username don't have a wall page.

2 votes

Well, I was trying to enter Trust & Betrayal wall page (via the button that says 'Wall' on the top right corner of his profile) and it just came up with 'Page Not Found'.

I thought it may have been because of the & in his name. Therefore, I searched up and found another user named Luius & Lae, and alas, he had the same problem, probably because of the evil &.
enter image description here

So yeah, can you fix this, pwease Master Pokemaster?? :3
EDIT: If you don't know what I'm talking about, just click here and here.

asked Dec 20, 2013 by !'•-Indigo-•'!
edited Dec 20, 2013 by !'•-Indigo-•'!
Dang it. '&' was going to be in my next username.
They both have walls for me.
They don't for me.
Indigo means that the wall tab doesn't work.

As shown in the URL of this page, instead of reading the user as Trust%20&%20Betrayal as it should, it reads it as Trust+%26+Betrayal. From my knowledge %26 is widely used in URLs to represent "&" similar to how "!" is represented with %21 (or something like that) unless in a query or something along them lines. I think the problem is that the HTML reads the link to display & first but after that it decodes it into %26 which reads as a new user that doesn't exist. Or at least I think thats what happens. I go to school to learn Math, English and Science not this shizzle so don't blame me if I'm wrong.
Yeah, those sort of symbols have a special code, and it seems the browser reads the link wrong. :3
Thanks for reporting this, I will check into it and answer when it's fixed.

1 Answer

1 vote

This has been fixed now.

answered Jun 3 by Pokemaster