PokéBase - Pokémon Q&A
0 votes
232 views

Whenever I try to connect to internet on Pokemon X, it says that a newer version of the software is needed. I have tried everything, and I am wondering if it is because I have a game card for Pokemon X, and not a download from the store. Can anyone help me?

by
edited by
Have you went onto the 3DS Eshop and found the 1.5 patch for Pokémon X.

1 Answer

1 vote

Nothing is wrong with your 3DS or copy of Pokemon X. In order to go on to the internet, You'll need to download the latest Patch (ver 1.5) corresponding to the version of the game you have from the Nintendo Eshop. The patch/update is Free of Charge.

Source: Knowledge and Experience
Hope this helps :)

by